本文介绍通过远程桌面连接Windows云服务器提示“远程桌面用户组没有该权限”错误的解决方案。
问题描述
本地客户端通过远程桌面连接轻云互联Windows云服务器时提示“远程桌面用户组没有该权限”错误
问题原因
无法远程连接Windows云服务器可能有以下两种原因:
-
云服务器内的本地安全策略配置不正确。请参考方案一:修改本地安全策略进行修复。
-
云服务器未添加普通用户远程登录的权限。请参考方案二:为普通用户增加远程登录权限进行修复。
解决方案
根据实际情况,选择对应方案进行解决。本文以Windows Server 2012操作系统为例。
方案一:修改本地安全策略
-
使用电脑内远程桌面连接您的云服务器或者使用面板内控制台VNC方式登录机器实例。
-
右键单击开始,然后单击运行。在运行对话框中输入
gpedit.msc
命令,然后单击确定,进入本地组策略编辑器页面。 -
在本地组策略编辑器页面中,单击计算机配置 > Windows设置 > 安全设置 > 本地策略 > 用户权限分配。
-
在用户权限分配页面中,双击拒绝通过远程桌面服务登录,进入拒绝通过远程桌面服务登录 属性窗口。
-
在拒绝通过远程桌面服务登录 属性窗口中,查看有无Remote Desktop Users和需要登录的域用户账号,如果存在请删除。
-
在用户权限分配页面中,双击允许通过远程桌面服务登录,进入允许通过远程桌面服务登录 属性窗口。
-
在允许通过远程桌面服务登录 属性窗口中,查看有无Remote Desktop Users和需要登录的域用户账号,如果没有请添加。
-
使用新添加的用户在另一台主机上远程登录Windows实例, 确认可以正常远程连接Windows实例。
方案二:为普通用户增加远程登录权限
-
使用电脑内远程桌面连接您的云服务器或者使用面板内控制台VNC方式登录机器实例。
-
进入计算机管理页面。
-
选择开始,单击服务器管理器。
-
在服务器管理器页面,单击所有服务器,在服务器框中,右键单击对应的服务器,单击计算机管理。
-
-
在计算机管理页面,右键单击系统工具 > 本地用户和组 > 用户,单击新用户(N),在新用户对话框中新建一个对应的用户,本文以新建test用户为例。
-
用户创建成功后,右键单击test用户名,选择属性(R) > 隶属于,单击添加,将用户添加到Remote Desktop Users组中,此时普通用户就可以远程登录。
说明Remote Desktop Users组为授权远程登录权限的组,添加到这个组中的用户都被授予远程登录的权限。